Robert McLaws: Windows Edition

Blogging about Windows since before Vista became a bad word

FINALLY, Site Issues Solved!

After spending the last several months beating my head against the desk with the issues I've been having here at Windows-Now.com, I finally caved in last night and coughed up the $100 to sick Microsoft's IIS6 PSS on it. I wasn't sure if I had my SQL server set up wrong, or if I screwed up some stupid IIS6 AppPool setting.

So a really nice guy named Adam e-mailed me this morning, and was a HUGE help. It turns out, they use an extremely stripped-down version of LiveMeeting to see your desktop, and they watch you as you DRP into your server and do some troubleshooting. I waited for the problem to happen, did a memory dump, and uploaded it to him. Within an hour, he had the answer. It was probably the best Tech Support experience I've ever had.

It turns out, the problem lies in the way Community Server 2.1 tracks page views. I had noticed that my page views weren't incrementing nearly as much as they used to, which I thought was strange since site traffic has been steadily increasing. Well, the task that updates the page view counts in the database was stopping everything waiting for a response, which never came. So the "thread" the site ran on would wait for 90 seconds, until the request timed out. Then the site would start responding again.

So while Telligent tracks down the issue and fixes it, I've removed the whole reporting module from the system, and the site has returned to it's speedy self. I feel like a giant weight has been lifted off my shoulders. Seriously, when the site responded the second I called it up after removing the offending HttpModule, and it kept responding after all the CSJobs had ran 15 minutes later... I'm pretty sure I had a small orgasm. If I was a smoker I would have had a cigarette. It's been THAT stressful.

Anyways, I'm going to relax for a little bit, and then I have some big news to share. Thanks for hanging with the site through all this, and it's OK to link to us again. Thanks guys!

UPDATE: Telligent rushed in and quickly provided a fix, which was a variation on one that was posted a couple weeks ago. I talked about it more on my personal blog. Thanks Telligent!

PostTypeIcon
1,895 Views

Comments

  • CONGRATS!

    March 15, 2007 6:55 PM
  • suril89 said:

    W00t!!!  Finally, I'm glad. :) :) :)

    I have really come to love your site, glad it's finally fixed.

    March 15, 2007 7:50 PM
  • Martien said:

    I hope you did clean your underware after this :D

    March 16, 2007 12:28 AM
  • Tony Gulino said:

    Great job! I know the feeling of finally figuring something out, then watching the stress instantly (or gradually) fade away after the problem is fixed. Programmers have the best orgasms. Few and far between, but the best!

    March 16, 2007 4:02 PM